DeSmuME Manual for the Linux GTK+ port

From DeSmuME
Jump to: navigation, search

NOTE: This refers to the 0.9.2 revision of desmume, and may or may not accurately reflect the current revision.

This page is seriously outdated for 0.9.11 svn version.


Contents

Quick Getting Started Guide

Due to the numerous different distributions and hardware platforms Linux runs on, desmume for Linux is only offered in source code form. This means you have to rely on packages available from your distribution or build it yourself. If you do not know how to do this, please refer to Installing DeSmuME from source on Linux.

Once you have desmume installed, you will have 3 different Linux ports to choose from: gtk+, glade, and a command line port. This manual is about the GTK+ port. You can start it by typing 'desmume' on the command line.

When you start the emulator for the first time, you probably just want to play a certain game. You can do this by going to 'File' in the menu, and selecting 'Open'. This will open up a file chooser, within which you can browse to the rom (nds file) that you wish to play. Once the game has finished loading (and this should only take a few seconds at most), you need to start the game. You can do so by choosing 'Emulation|Run' from the menu, or by clicking on the 'Run' button.


Menu Layout

The rest of this manual will be spend on explaining all the other options in the menu.


File Menu

File | Open

This option lets you browse to and selct a rom file to open in the emulator.

File | Save state to

Imagine you have gotten to a certian point in a game, and you need to do something else. The emulator let's you save the current state of the game, so that you can continue the game later at precisely the same point somewhere in the future. This option lets you choose a random name for your savestate file.

Please note that the use of SAVESTATES is discouraged, as these are likely to break between emulator versions. Instead use SAVE FILES. These are likely to survive between emulator versions. This means that you will have to use save points within the game. SAVE FILES are stored in .sav files.

File | Load state from

Once you have saved a game's position, or 'state', you can load it again with this option. This option works in tandem with 'Save state to', and lets you select any randomly named savestate file.

File | Save state

This option works fairly similair to the 'Save state to' option, altough it let's you save numbers instead of specifying a chosen name. Also, all the states saved via this option end up with a pre-determined name of 'game (rom) name'.dsx. So if the game is called MyGame, the first savefile will be called MyGame.ds0, the second one MyGame.ds1, etc.

File | Load state

This option let's you load the states that you saved via the 'File | Save state' option

File | Record movie to

This option lets you record the gameplay in TAS format, see http://tasvideos.org for details on TAS (tool-assisted speedruns).

File | Play movie from

This option lets you playback a pre-recorded TAS movie.

File | Stop movie

This options lets you stop recording a TAS movie.

File | Take a screenshot

This option lets you take a quick screenshot of the current display in the emulator windows. The image is in PNG format and is saved in current directory. Hotkey is Ctrl+S.

File | Quit

Selecting this option terminates the emulator.

Emulation Menu

Emulation | Run

After you have opened a rom file, you need to start (run) it. This menu option does that. Alternatively, you can press the 'Run' button.

Emulation | Pause

Choosing this option causes the emulation to 'freeze', or pause.

Emulation | Reset

Selecting this option resets the rom file you opened, and makes it start at the very beginning just as if you just opened and ran the rom.

Emulation | Enable Audio

This option lets you choose, by placing a checkmark, if you want to hear audio or not.

Emulation | Fake mic noise

This option lets you play a dummy or fake mic noise, even if there is no microphone attached. Unfortunately, in all known versions of GTK desmume, this value is hidden when ALSA is detected at compilation time, as the emulator expects you to use a mic then. I know, this is lame.

Emulation | Frameskip

This option lets you select how many frames should not be displayed, in order to gain speed improvements. If you have speed problems, you could decide to skip (not display) one or more frames in order to improve the speed.

Emulation | Layers

This option lets you view the Layers one by one.

Emulation | Cheat

This option pulls down a drop-down menu, and presents the options list and search. Be aware though, that cheats are sort of half baked right now. If you are not having luck, wait for some news on an improved cheat system. Also, it is impossible yet to use "commercial" codes, such as Action Replay and Codebreaker, so what you'll have to do is manually search for, and alter the memory positions to your advantage. They are called 'raw' or 'internal' cheats. There's an excellent article in the wiki on Using Cheats in DeSmuMe . In post-0.9.2 development builds, there is also the support for Action Replay cheat codes.

Emulation | Cheat | Search

Choosing 'search' will let you search for cheats. Please refer to the article Using Cheats in DeSmuMe for further details on how to use the cheat mechanism in desmume.

Emulation | Cheat | List

Choosing 'list' will list all the currently known cheats. Please refer to the article Using Cheats in DeSmuMe for further details on how to use the cheat mechanism in desmume.


Config Menu

Config | Saves

This option lets you specify the save type of a particular game. The default is 'autodetect'. However, this is not fail-safe in all cases, so you might need to manually select one of the other savetypes.

Config | Rotation

This option lets you rotate the screens by a pre-determined value.

Config | Interpolation

This lets you set the interpolation to either 'Nearest' or 'Bilinear'.

Config | Gap

This option lets you select whether you want a 'gap' between the upper and lower screens.

Config | Edit Controls

This option lets you configure keyboard keys.

Tools Menu

Tools | IO Regs view

This option lets you view some of the the ARM7 and ARM9 I/O registers.

Help Menu

Help | About

This option displays the version you are using.

Personal tools