DeSmuME Manual for the Linux GTK+ port

From DeSmuME
Revision as of 08:12, 7 April 2009 by 80.57.226.112 (Talk)
Jump to: navigation, search

Contents

Quick Getting Started Guide

Due to the numerous different distributions and hardware platforms Linux runs on, desmume for Linux is only offered in source code form. This means you have to build a binary (compile) Linux for yourself. If you do not know how to do this, please refer to Installing DeSmuME from source on Linux.

Once you have build and installed the binary, you will have 3 different Linux ports to choose from: desmume gtk+, desmume gladde, and a desmume command line port. This manual is about the GTK+ port. You can start it by typing 'desmume' on the command line.

When you start the emulator for the first time, you probably just want to play a certain game. You can do this by going to 'File' in the menu, and selecting 'Open'. This will open up an explorer window, within which you can browse to the rom (nds file) that you wish to play. Once the game has finished loading (and this should only take a few seconds at most), you need to start the game. You can do so by choosing 'Emulation|Run' from themenu, or by clicking on the 'Run' button.


Command Line Options

This port of desume has several command line options, which will be listed here :


--load-slot=NUM

Loads savegame from slot NUM

--opengl-2d

Enables using OpenGL for screen rendering

--soft-convert

Use software colour conversion during OpenGL screen rendering. May produce better or worse frame rates depending on hardware.

--3d-engine=ENGINE

Select available 3d emulation: 0 = 3d disabled 1 = internal desmume software rasterizer (default) 2 = osmesa or gtkglext opengl (if available, depending on compilation options, see desmume --help)

--disable-sound

Disables the sound emulation

--disable-limiter

Disables the 60 fps limiter

--arm9gdb=PORT_NUM

Enable the ARM9 GDB stub on the given port

--arm7gdb=PORT_NUM

Enable the ARM7 GDB stub on the given port

--cflash=PATH_TO_DISK_IMAGE

Enable disk image GBAMP compact flash emulation

-h, --help

Show summary of options.

-v, --version

Show version of program.


Menu Layout

The rest of this manual will be spend on explaining all the other options in the menu.


File Menu

File | Open

File | Take a screenshot

File | Quit

Emulation Menu

Emulation | Run

Emulation | Pause

Emulation | Reset

Emulation | Enable Audio

Emulation | Frameskip

Emulation | Saves

Emulation | Layers

Config Menu

Config | Edit Controls

Tools Menu

Tools | IO Regs view

Help Menu

Help | About

Personal tools