DeSmuME Manual for the Linux Glade port

From DeSmuME
Jump to: navigation, search

NOTE: This refers to the 0.9.2 revision of desmume, and may or may not accurately reflect the current revision.


Quick Getting Started Guide

Due to the numerous different distributions and hardware platforms Linux runs on, desmume for Linux is only offered in source code form. This means you have to rely on packages available from your distribution or build a binary (compile) Linux for yourself. If you do not know how to do this, please refer to Installing DeSmuME from source on Linux.

Once you have build and installed the binary, you will have 3 different Linux ports to choose from: desmume gtk+, desmume glade, and a desmume command line port. This manual is about the glade port. You can start it by typing 'desmume-glade' on the command line.

When you start the emulator for the first time, you probably just want to play a certain game. You can do this by going to 'File' in the menu, and selecting 'Open'. This will open up an explorer window, within which you can browse to the rom (nds file) that you wish to play. Once the game has finished loading (and this should only take a few seconds at most), the game will start automatically.

Command Line Options

This port of desume has several command line options, which will be listed here :


Loads savegame from slot NUM


Use software colour conversion during OpenGL screen rendering. May produce better or worse frame rates depending on hardware.


Select available 3d emulation:

0 = 3d disabled
1 = internal desmume software rasterizer (default)
2 = osmesa or gtkglext opengl (if available, depending on compilation options, see desmume --help)


Disables the 60 fps limiter


Selects savetype:

0 = Autodetect (default)
1 = EEPROM 4kbit
2 = EEPROM 64kbit
3 = EEPROM 512kbit
4 = FRAM 256kbit
5 = FLASH 2mbit
6 = FLASH 4mbit


Set the language in the firmware, LANG as follows:

0 = Japanese
1 = English
2 = French
3 = German
4 = Italian
5 = Spanish


Enable the ARM9 GDB stub on the given port


Enable the ARM7 GDB stub on the given port

-h, --help

Show summary of options.

-v, --version

Show version of program.

Menu Layout

The rest of this manual will be spend on explaining all the other options in the menu.

File Menu

File | Open

This option let you open and start a commercial or homebrew application.

File | Save State

This option lets you save the state / condition the emulator is currently in.

Please note that the use of SAVESTATES is discouraged, as these are likely to break between emulator versions. Instead use SAVE FILES. These are likely to survive between emulator versions. This means that you will have to use save points within the game. SAVE FILES are stored in .sav files.

File | Load State

This option lets you load a previously saved state / condition of the emulator.

File | print Screen

This option let's you take a quick screen print of the current emulation windows.

File | Quit

This option lets you exit the emu8lator

Emulation Menu

Emulation | Execute

This option start running, or emulating, the rom file you loaded via the file menu.

Emulation | Pause

This option lets you pause or 'freeze' the emulation or execution of the current rom.

Emulation | Reset

This option resets the currently loaded rom right back to the start, as if you just opened and executed the rom.

Emulation | Layers

The Nintendo DS display is made up of several different 'layers', and this option lets you choose which layers you do or don't want to see. This is especially useful when debugging a problem, and finding out in which layer the bug occurs.

Emulation | Frameskip

This option lets you determine how many frames to 'drop', or not display during the emulation. The default is 'zero', which means display all frames. If you are experiencing speed problems, you can try to see if skipping frames helps speed up the execution, in favor of the accuracy of drawing all frames.

Emulation | Size

This option lets you resize the desmume windows.

Config Menu

Config | Saves

This option lets you select the savetype of the rom. The default is 'automatic', which is sufficient in most cases. However, the automatic detection option is not perfect, and you may find it necessary to set this option manually.

Config | Keyboard controls

This option let's you define the keyboard controls, and map the Nintendo DS controller buttons to buttons on the keyboard.

Here are the default key mappings (they may be subject to change):

 Up arrow             - Up
 Left arrow           - Left
 Down arrow           - Down
 Right arrow          - Right
 x                    - A button
 z                    - B button
 s                    - X button
 a                    - Y button
 q                    - Left Trigger
 w                    - Right Trigger
 Enter                - Start button
 Right Shift          - Select button
 Backspace            - Lid fold/unfold
 n                    - Frame advance
 Space                - Pause/Unpause 
 p                    - Load current state
 1,2,3,4,5,6,7,8,9,0  - Select current state
 F1-F10               - Load relevant state
 Shift+F1-F10         - Save relevant state

Config | Joystick controls

This option let's you configure your joystick.

Config | Audio on

This option lets you turn the audio emulation on or off.

Config | True Gap

This option displays a free space or 'gap' between the two panels. It is roughly the same size as on a real Nintendo DS.

Config | No Gap

This option disables the disoplay of a 'gap' between the two panels.

Config | Right Screen

Selecting this option moves the bottom panel to the right of the upper panel, instead of below it.

Config | Rotate screen 0

This option disables screen rotation.

Config | Rotate screen 90

This option rotates the panels 90 degrees.

Config | Rotate screen 180

This option rotates the panels 180 degrees.

Config | Rotate screen 270

This option rotates the panels 270 degrees.

Tools Menu

Tools | Io regs

This option lets you view the IO registers of the emulated Nintendo DS.

Tools | View Memory

This tool displays the ARM7 and ARM9 memory.

The "ARM9|ARM7" drop down menu allow you to choose wether you wish to see the ARM7 memory or the ARM9 memory.

The "View mode" radio buttons allow you to choose how the memory will be shown:

  • 8-bit : shows the memory as bytes
  • 16-bit : shows the memory as words
  • 32-bit : shows the memory as dwords

The "Go To" textbox and button allow you to jump to a different address:

  • Enter an hexadecimal address without 0x prefix, with up to 8 digits
  • Click "Go" to jump to the entered address.

Tools | View Palette

This option lets you view the palette of the emulated Nintendo DS.

Tools | View Tiles

This option lets you view the tiles of the emulated Nintendo DS.

don't use this - tileview is out-of-date in glade port - it will just show some garbage and halt the game

 ? Menu

 ? | About

This option displays the version of desmume that you are using.

Personal tools