DeSmuME Manual for the Linux Glade port

From DeSmuME
(Difference between revisions)
Jump to: navigation, search
Line 47: Line 47:
  
 
=== File Menu ===
 
=== File Menu ===
 
  
 
==== File | Open ====
 
==== File | Open ====
 +
 +
==== File | Save State ====
 +
 +
==== File | Load State ====
 +
 +
==== File | print Screen ====
 +
 +
==== File | Quit ====
 +
 +
 +
=== Emulation Menu ====
 +
 +
 +
==== Emulation | Execute ====
 +
 +
 +
==== Emulation | Pause ====
 +
 +
 +
==== Emulation | Reset ====
 +
 +
 +
 +
=== Emulation | Layers ===
 +
 +
 +
=== Emulation | Frameskip ===
 +
 +
 +
 +
=== Emulation | Size ===
 +
 +
 +
 +
 +
 +
 +
=== Config Menu ===
 +
 +
 +
==== Config | Saves ====
 +
 +
 +
==== Config | Keyboard controls ====
 +
 +
 +
==== Config | Joystick controls ====
 +
 +
 +
==== Config | Audio on ====
 +
 +
 +
==== Config | True Gap ====
 +
 +
 +
==== Config | No Gap ====
 +
 +
 +
==== Config | Right Screen ====
 +
 +
 +
==== Config | Rotate screen 0  ====
 +
 +
==== Config | Rotate screen  90 ====
 +
 +
==== Config | Rotate screen  180 ====
 +
 +
==== Config | Rotate screen  270 ====
 +
 +
 +
=== Tools Menu ===
 +
 +
==== Tools | Io regs ====
 +
 +
 +
==== Tools | View Memory ====
 +
 +
 +
==== Tools | View Palette ====
 +
 +
 +
==== Tools | View Tiles ====
 +
 +
 +
=== ? Menu ===
 +
 +
==== ? | About ====

Revision as of 08:23, 7 April 2009

Contents

Quick Getting Started Guide

Due to the numerous different distributions and hardware platforms Linux runs on, desmume for Linux is only offered in source code form. This means you have to build a binary (compile) Linux for yourself. If you do not know how to do this, please refer to Installing DeSmuME from source on Linux.

Once you have build and installed the binary, you will have 3 different Linux ports to choose from: desmume gtk+, desmume glade, and a desmume command line port. This manual is about the glade port. You can start it by typing 'desmume-glade' on the command line.

When you start the emulator for the first time, you probably just want to play a certain game. You can do this by going to 'File' in the menu, and selecting 'Open'. This will open up an explorer window, within which you can browse to the rom (nds file) that you wish to play. Once the game has finished loading (and this should only take a few seconds at most), the game will start automatically.


Command Line Options

This port of desume has several command line options, which will be listed here :


--load-slot=NUM

Loads savegame from slot NUM

--soft-convert

Use software colour conversion during OpenGL screen rendering. May produce better or worse frame rates depending on hardware.

--3d-engine=ENGINE

Select available 3d emulation: 0 = 3d disabled 1 = internal desmume software rasterizer (default) 2 = osmesa or gtkglext opengl (if available, depending on compilation options, see desmume --help)

--disable-limiter

Disables the 60 fps limiter

--arm9gdb=PORT_NUM

Enable the ARM9 GDB stub on the given port

--arm7gdb=PORT_NUM

Enable the ARM7 GDB stub on the given port

-h, --help

Show summary of options.

=== -v, --version Show version of program.



Menu Layout

The rest of this manual will be spend on explaining all the other options in the menu.


File Menu

File | Open

File | Save State

File | Load State

File | print Screen

File | Quit

Emulation Menu =

Emulation | Execute

Emulation | Pause

Emulation | Reset

Emulation | Layers

Emulation | Frameskip

Emulation | Size

Config Menu

Config | Saves

Config | Keyboard controls

Config | Joystick controls

Config | Audio on

Config | True Gap

Config | No Gap

Config | Right Screen

Config | Rotate screen 0

Config | Rotate screen 90

Config | Rotate screen 180

Config | Rotate screen 270

Tools Menu

Tools | Io regs

Tools | View Memory

Tools | View Palette

Tools | View Tiles

 ? Menu

 ? | About

Personal tools